Friday, July 24, 2009

Padre's Perl 6 version 0.54

Padre Perl 6 plugin (0.54) is now on CPAN. This release breaks compatibility with older Padre versions so you need to upgrade to Padre 0.41. A lot of refactoring was done by Gabor Szabo to re-use Padre's new mime-type to highlighter list support.


A plugin now can contribute one or more highlighters to a mime-type. So for example, Parrot plugin contributes a Perl 6 highlighter to Padre which is based on PGE (Parrot Grammar Engine) highlighter. This used to be a part of Perl 6 plugin.

To install Padre Perl 6 support, cpan Padre::Plugin::Perl6. For Padre or Perl 6 help, please visit #padre on irc.perl.org or #perl6 on irc.freenode.net.

No comments: